查看: 2019|回复: 0

[IOS开发教程] cocoapods的安装和安装过程中遇到的问题

发表于 2018-2-19 08:00:04

1.$ ruby -v //查看当前的ruby版本,我的版本是ruby 2.0.0p648 小于2.2 所以在下面的安装cocoapods时会遇到问题

2. $ gem sources -l //查看当前ruby源,默认为 https://rubygems.org/ 因为防火墙的问题我们需要更换成国内的镜像

3. $ gem sources --remove https://rubygems.org/ //移除之前的ruby源

4. $ gem sources --add https://gems.ruby-china.org/ 或 gem sources -a https://gems.ruby-china.org/ 替换添加国内的镜像源 或 https://ruby.taobao.org/ (听说这个镜像好像停止维护了,还是可以用的)

5. $ sudo gem install cocoapods //安装cocoapods

6.用$ sudo gem install -n /usr/local/bin cocoapods //命令安装pods时由于ruby版本小于2.2所以会出现下面的错误,

  查看了一下ruby的版本像第一步说的,版本小于2.2所以没有安装成功,如果你的ruby版本大于2.2可以直接跳到第12步

  如下图:

7.这里就需要要升级Ruby版本,查看目前的所有ruby版本:

$rvm list known

执行命令后显示command not found 就需要先安装rvm

$curl -L get.rvm.io | bash -s stable //安装rvm

如果已安装会列出所有的ruby版本:

下图是我的电脑里没有rvm,并进行了安装:

rvm安装的时间比较长,中途会需要输入两次回车,和一次密码,时间会比较长一些

8.安装成功以后执行 $ source ~/.rvm/scripts/rvm 什么都不输出是对的,然后再执行 rvm -v 查看当前的rvm的版本

9.然后就是用rvm安装ruby环境,当然这里要安装大于2.2的版本。我这里安装的是2.4,可以用vrm list known 查询当前最高版本

输入指令:$ rvm install 2.4.0 //安装2.4版本的ruby

这里时间会很长。成功如图

10,可以用 $ ruby -v 查看当前的ruby版本

11. 搞这么半天接下来就可以安装cocoapods了 ,执行 $ sudo gem install cocoapods //安装cocoapods 会提示输入密码(输入密码不会有反应继续回车就可以)。下图是安装成功部分截图:

12: 执行 pod --version //查看当前cocoapods 查看gem ruby的版本号可以用:sudo gem -v

13:cd Desktop //进入桌面 可以通过拖项目的方式打开

$ cd /Users/mac/Desktop/测试/ceshiSecond //打开项目的目录

ls //查看当前目录下面的目录

$ vim Podfile //使用vim编辑文件

进入如下界面:

进来之后按键盘'i'键

下面的"Podsfile" 0L, 0C会变成-- INSERT --

然后就可以编辑文字了,输入以下文字

解释一下

platform :ios, '7.0'下载库支持的iOS最低版本是iOS 7.0,

'ceshiSecond'就是自己的工程名字,

pod 'AFNetworking', '~> 3.1.0'代表要下载的AFNetworking版本是3.1.0及以上版本,还可以去掉后面的'~> 3.1.0',如果没有这样~> 3.1.0,下载AFNetworking是最新版。

按esc 输入:wq保存

14. $ pod install //把库下载到xcode中 需要一段时间

关闭xcode窗口,再打开会项目中会多一个 .xcworkspace的文件 ,以后双击它就可以打开项目了

有不足的对方,还请多多指教。。。



回复

使用道具 举报